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What is Aladdin

Aladdin is a spreadsheet based multi-currency-pricing model, which prices a wide variety of products (see also MBRM_Aladdin_Models_and_Products.doc and MBRM_Aladdin_Overview.pps and MBRM_Introduction_to_CYGNIFI_software.doc)
Swaps:


Vanilla


CMS


CUPS


Sinking Fund


Knock In/Out

Options:


Caps


Floors


Swaption


Chooser/Survivor


Sticky Cap


Sticky Cap Option

Currencies supported include all of the major trading currencies plus emerging markets. Currency support can be extended as required.

Fundamental Concepts

Aladdin organizes the information required to price an instrument into a market workbook and a trade workbook.

The market workbook contains all currencies and associated market rates required by the trade.

The trade workbook is where the structure of the deal is modeled.

The trade and market workbooks are kept together as pairs, although it is possible for many trade workbooks to share one market workbook.

Getting Started

The MBRM auto-install program will create a program group called "MBRM - Aladdin" (accessed via Windows' "Start" button, then "Programs").  Clicking on the "Aladdin" shortcut in the "MBRM - Aladdin"  program group will start Excel, and Aladdin (Aladdin.xls) will begin to load. The loading process needs to load the Analytics Library, the Aladdin Utility Libraries and the Visual Basic management code. While this is happening you will see the Aladdin banner. Once loaded, you will see a blank Excel, with only File, Aladdin and Help menus available.

Aladdin Menus

The Aladdin menus provide the main interface with the system.

New Trade/Market

Trades are modeled in a trade workbook, and references are made to a market workbook.

Selecting this menu option will give you the default trade and market pair, which can then be modified according to your requirements.

New Market

To build up a Market sheet on its own, you can select this menu option.

Once complete, use the File->Save menu option to save your work.

Open Trade/Market

Previously saved trades can be reloaded with this menu option.

Select the trade (usually having an "XLT" file extension), and both it and its associated market will be loaded for further work.

Error Logging

Aladdin will use the standard analytics library error log (c:\aladdin.log) for error messaging.

However, you must first activate the error logging per session. Simply select the "Start Logging" menu option.

Error logging will stop automatically when you leave Aladdin, but may also be stopped while still using the spreadsheet by using the "Stop Logging" menu.

At any time, the contents of the error log may be viewed either by selecting the "View" menu option, or by using Ctrl-Shift-E keystrokes.

Using the Error Log

The error log serves as a useful source for problem solving, when the spreadsheet shows N/A or #NUM where values are expected.

Turning the error log on is done through the Aladdin->Error Log->Start Logging menu option.

The error log can be viewed with the Aladdin->Error Log->View menu option, or by using the Ctrl+Shift+E key combination. Press the Exit button to remove the log from the screen, or the Clear button to delete the log completely.

Turn the error log off with the Aladdin->Error Log->Stop Logging menu option.

To find a specific problem, with error logging turned on, view the error log, and press Clear to remove other messages. Then recalculate the spreadsheet (make a change somewhere innocuous to force this if necessary), and then view the log again. Any messages will now be isolated in the log, which should aid the resolution.

Overall Structure

The Aladdin application allows trades to be modeled using a combination of market data and trade structures.

Market data is kept in the market workbook, and the trade structures are set up within the trade workbook.

Color-Coding

Color is used to highlight areas as follows:

- white cells for user input/modification

- blue cells for default values that may be modified with care

- grey cells for default values and formulae that should not be modified

Market Workbook

The market workbook is where currency rates and information is contained, and is referenced by a trade workbook.

The market workbook can contain any number of currencies, but must always contain USD, in order that credit may be calculated.

A default currency can be setup when loading a new market workbook.

Common Page

The common page within the Market workbook provides information common to currencies, or cross currency information.

Currency Page

A currency page defines all of the market data and conventions that are applicable to the currency.

Market Data

All data used in pricing is stored in text files.  These files are imported into Aladdin via the Market->Import menu option within the Market workbook.  These text files are stored on the hard disk from which Aladdin is installed on.  To update these files, you must upload your new data file to the hard disk.  Then import the data into Aladdin as described above.  The format of the text files can vary based on the type of data.  

Trade Workbook

The trade workbook is where trades are modeled. However, the book itself consists of a credit page, a hedge page, a summary (P&L) page, and individual trade pages.

The Hedges page is where hedge costs for the trade are calculated. Aladdin will calculate 1+i Defeasance and tweaked hedges, as required.

The Summary page gives a P&L view of the trade, similar in format to the Djinni pricer. All individual trade page valuations are brought together in the summary sheet to give the overall trade valuations.

A trade may consist of one or more trade pages. Each page has one payment currency, and any valuations on the page are made in the payment currency. Hence a cross-currency swap, which requires 2 payment currencies, requires 2 trade pages. The left-hand side of a trade page gives a summary of the trade PV's at useful dates, along with conventions for the payment currency.

Trade pages are selected from a menu of possible templates.

A trade must always have at least one trade template page.

Summary Sheet

The summary sheet provides the total valuation for the trade, in USD, summing the USD PV for each trade page.

The hedge costs are also reported in the same manner.

Other charges may be included by manual input in the total column "Other Charges" cell.

Hedge Sheet

The hedge page gives a full report for hedge positions in each payment currency involved in the trade.

A variety of tables are presented for each currency, which are populated according to the tweak menu options selected. From left to right are:

Tweaked Swap Position - select Tweak->Rates on the menus to report.

Tweaked Futures Hedges - where futures are included in the zero curve, Tweak->Rates will provide futures hedges.

Base Volatility - select Tweak->Base Vol menu options. This tweaking can be controlled by the tweak options provided under the base volatility market data in the market workbook.

Trade Page

A trade page (template) defines a structure with which to model instruments.

The instruments modeled will depend upon the template being used.

A trade page will always have a representative section within the Summary page.

Trade page left-hand side

The left-hand side of the trade page is standard across all templates.

At the top is the payment currency of this sheet. This currency code determines where the remaining currency dependant information is taken from.

The ccy PV, ccy Value Date is derived from the calculations on the trade sheet. this number is translated into USD PV, Trade Value Date for reporting on the Summary page.

Cash flow Matrices, Zero Curves, Volatility Surfaces and N-Factor Parameters are all spreadsheet objects, copied in from the ccy market sheet for convenience.

Starting a New Trade

Select Aladdin->New Trade/Market from the menu.

This will give you 2 workbooks - MARKET.XLS and TRADE.XLS - for the market data and the trade respectively.

You will be prompted to select the type of trade page to start with. Select that which is most appropriate to the instrument being modeled.

The market book will have USD market data, and the trade book will include a single USD trade template of the type selected.

The market book is known as the "Linked Market", and will contain all of the market data that the trade requires. Because trade valuations are always converted to USD, the market workbook must always have a USD entry.

Changing the date

All dates are derived from "Today", which can be changed within the spreadsheet, without having to change any system dates.

By default, a new market will have Today set correctly off the PC's clock. Ensure the market workbook is active.

Select the Common sheet.

Update the date in cell C2.

Recalculate with F9.

This will affect all trade sheet dates and zero curve dates.

Adding extra market sheets

Extra market sheets are required where currency information is required that doesn't already appear in the market workbook.

In most cases, the trade workbook will ensure that these requirements are met by automatically added missing currencies.

However, if it is necessary to add a currency by hand:

Ensure a market workbook is active.

Select Market->Sheet->Add from the menu.

Select the number of sheets to add. Enter a number and press the OK button.

Select the appropriate currency code from the list. Highlight the code and press the OK button.

Adding extra trade sheets

Extra trade sheets are required where payments are being made in more than one currency - each trade sheet has one payment currency.

Ensure a trade workbook is active.

Select Trade->Sheet->Add from the menu.

Select the type of template sheet required from the available options. Highlight the required template type and press the OK button.

Select the number of sheets to add of this type. Enter a number and press the OK button.

Generally, the sheet will be added with a USD payment currency. This may be changed as required.

If prompted, select whether to link dates to an existing trade page. This allows all of the payment dates for a new sheet to match the payment dates on an existing sheet. Changes to the payment schedule, at any time, in the existing sheet will also be made to this page.

Changing the payment currency

The payment currency is recorded in the top left corner of a trade sheet, and is the currency in which cash flows are paid. Cash flows may be derived from rates in other currencies, but will be made in the payment currency.

To change the payment currency for a trade sheet, use the Trade->Currency menu option.

Select the currency code from the available list, and press the OK button.

If the chosen currency is not already available within the market book, then you will be prompted to add it. Select Yes to proceed, and No to cancel the currency change.

Using the solving mechanism

Solving is used to establish the correct value to use for a particular component of a trade such that a particular condition is met.

Components that are solved for are generally fixed coupons and spreads, such that the residual value of the trade is 0.

In order to solve, the value to be solved for (the solve variable), and the condition (the solve constraint) need to be defined.

In all cases, solving is attempting to find the value of the variable such that the constraint has a 0 value. This also means that the calculation of the constraint value must be directly related to the solve variable.

Setting the variable

To set the variable, select the appropriate single cell, and use the Trade->Solve->Set Variable menu option or the Ctrl+Shift+A key combination.

Setting the constraint

To set the constraint, select the appropriate single cell, and use the Trade->Solve->Set Constraint menu option or the Ctrl+Shift+B key combination.

Solving

To solve, use the Trade->Solve->Solve menu option, or the Ctrl+Shift+C key combination.

The variable and constraint must be set prior to solving.

Example - Solving for a fixed rate on a CUPS sheet

The fixed rate of a swap can be solved for, with the assumption that (in this example) the residual value of the deal should be zero.

To set the variable, select the fixed coupon cell (CPN) on the trade sheet, and use the Trade->Solve->Set Variable menu option or the Ctrl+Shift+A key combination.

To set the constraint, select the summary page, and select the residual cell in the total column. Use the Trade->Solve->Set Constraint menu option, or the Ctrl+Shift+B key combination.

To solve, use the Trade->Solve->Solve menu option, or the Ctrl+Shift+C key combination.

This gives us the par swap coupon, and inspecting the trade sheet PV should show zero value.

Now include hedge costs by tweaking.

Now, re-solve the deal such that the residual value includes the hedge cost.

The PV of the deal should now be -hedge cost, giving a residual of 0.

Return to the trade page to see the solved value. You can use the Trade->Solve->Go To Variable as a quick navigation tool.

Example - Solving for a spread

The floating rate spread can be solved for in an interest rate swap, with the assumption that (in this example) the residual value of the deal should be zero.

Set up the spread flows in the cash flow areas.

Set the fixed coupon for the trade.

To set the variable, select the spread cell (SPD) on the trade sheet, and use the Trade->Solve->Set Variable menu option or the Ctrl+Shift+A key combination.

To set the constraint, select the summary page, and select the residual cell in the total column. Use the Trade->Solve->Set Constraint menu option, or the Ctrl+Shift+B key combination.

To solve, use the Trade->Solve->Solve menu option, or the Ctrl+Shift+C key combination.

This gives us the required spread without hedge costs.

Now include hedge costs by tweaking.

Now, re-solve the deal such that the residual value includes the hedge cost.

The PV of the deal should now be -hedge cost, giving a residual of 0.

Return to the trade page to see the solved value. You can use the Trade->Solve->Go To Variable as a quick navigation tool.

Tweaking

The tweaking options allow you to determine the hedge cost of the trade.

Tweak menu options are available from the "Trade" menu. Here you will find Tweak->All and Tweak->currency options. "Tweak All" will tweak the rates of all currencies that are present in the trade (and therefore slow), whereas "Tweak currency" will only tweak the rates of the active sheets' payment currency.

Tweak Rates

The Tweak->Rates menu option will recalculate the value of the trade, given increments in the yield curve.

The Tweak Size is configurable in the market sheet for a currency. By default, the Tweak Size is set to +1, but may be altered in direction and size.

Tweak Fx Rates

The Tweak->Rates menu option will recalculate the value of the trade, after the FX rate is scaled by 1.0001.

The USD/USD FX rate is never tweaked.

Tweak Base Volatility - Grid

The Tweak->Base Vol Grid menu option will recalculate the value of the trade, given increments in the grid points.

Each point in the grid is iterated over, and the trade repriced on each increment.

It is possible to control the area and number of points in the grid, which are tweaked through the options under the base vol import area.

Tweak Base Volatility - 1 Vega

The Tweak->Base Vol 1 Vega menu option will recalculate the value of the trade once, given an increment of 1% in the volatility across the grid.

Saving a Trade and Market

Modeled trades and their associated markets can be saved for further work.

Select the Trade->File->Save Trade/Market as menu option from the trade workbook menu.

Enter the pair name to use. By default, the trade workbook will be called name.XLT, and the market workbook will be called name.XLM. It is not possible to save the workbooks as TRADE.XLS and MARKET.XLS.

Select the directory in which to save the two workbooks.

Press the OK button.

If you only want to save the trade, deselect the "Save Linked Market" checkbox, before pressing OK.

If you want to start a new trade as well, select the "Open New Window" checkboxes as required.

If this is a previously saved trade and market, then use the Trade->File->Save Trade/Market menu instead. The name will remain the same.

Retrieving a Trade and Market

Modeled trades and their associated markets can be retrieved after saving.

Select the Aladdin->Open Trade/Market as menu option.

Select the trade to load. Its market will be loaded automatically.

The CUPS Template

The CUPS template is designed for modeling swaps and options on swaps.

Instrument coverage for the swaps sheet

Swaps- vanilla, CMS, cups, basis, cross-currency, cancelable/extenable

Caps/Floors : vanilla or any combination of. Options: binary, barrier, spread, basket

Swaption- European, multi-European, American
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Accrual/Payment Schedule Configuration

Payment frequency

The payment frequency defines the regular interval between coupon payments. 

The frequency of the accrual schedule should be the greater of any fixed/floating frequencies that are modeled on the same sheet. 

Valid letters are shown to the right of the cell. 

Effective date

The effective date can be used to move the start of the payments forward in time.

The cash flow streams will still be PV'd back to the currency value date.

1st Regular Accr Date / 1st Roll date

A front stub can be defined by setting this date forward from the effective date.

1st Regular Row / 1st Roll date

Setting this to n provides n additional rows where the payment date = effective date.

This is useful where multiple up-front payments are being made, and can be modeled separately.

Accrual Bad Day Convention

The accruals bad day convention controls how the unadjusted accrual end dates are moved to adjusted accrual end dates. 

Adjustment is made provided that the Adjust Dates flag is set as 1. 

Valid letters are shown to the right of the cell.

Payment Offset

The payment offset determines the number of days between the adjusted accrual end dates and the unadjusted payment dates. 

If required, the value should be entered as an integer.

Payment Bad Day Convention

The payment bad day convention controls how the unadjusted payment dates are moved to adjusted payment dates. 

Adjustment is made provided that the Adjust Dates flag is set as 1. 

Valid letters are shown to the right of the cell.

Coupon Payment Dates

Coupons will be paid (by default) on the Payment Adj. dates.

Trade maturity

The maturity of the trade is (accrual frequency * number of cash flow rows), notwithstanding any stubs or upfront rows. 

Use the Trade->Make Rows ... menu option to modify the maturity of the trade. 

It is recommended that only as many rows as necessary is used, to prevent unnecessary calculation
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Trade Principal Modeling

Principal

The principal for the trade sheet is set in the PPL cell. It should be adjusted for FX rates if applicable. 

It may be set negative to reverse the default direction of the coupon payments.

Principal Flows

The principal flows determine at which payment dates any principal exchanges occur.

Normally, you would have =PPL against the trade effective date, and =-PPL against the trade end date. 

If you require an amortizing or accreting stream, then these additional principal payments are set in the Principal Flow column.

For example, a 5 year annual amortizing stream would have =PPL against the effective date, and =-PPL/5 on each of years 1,2,3,4 and 5
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Cash flow Modeling

Fixed Cash flows

Fixed principal flows, coupon flows and any other fixed-style flows are modeled together, and summed into the Sum Fixed column. 

Fixed coupons are calculated as (fixed rate * outstanding principal * year fraction).

Floating Cash flows

Floating principal flows, coupon flows and any other floating-style flows are modeled together, and summed into the Sum Float column. 

Floating coupons are calculated as (floating rate * outstanding principal * year fraction).

Total PV

The summed Fixed and Floating cash flows are PV'd back to ccy Value Date, which are then summed together to give a total PV.

This value is used on the left-hand side as the PV of the trade, and hence on the Summary page.

Fixed Rate Definition
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Fixed Leg Section

The fixed leg section consists of visible rate/day count columns, and hidden accrual start/end and day count columns. 

The hidden columns may be made visible by selecting a cell within the fixed leg area and using the Trade->Fixed Rate->View More menu option, or the Ctrl-Shift-M key combination. They may be hidden again by using the Trade->Fixed Rate->View Less menu option, or the Ctrl-Shift-L key combination.

Fixed Rate Payment Frequency

The Frq cell determines the frequency at which the fixed rate is paid. 

It must be at most as frequent as the payment schedule frequency. If it is less frequent than the payment schedule frequency (e.g. annual against semi-annual schedule), then formulae for the fixed coupons should be deleted in the Fixed Cash flow area on the appropriate dates.

Fixed Rate Day Count Convention

The day count convention for the rate is derived from the Days and Basis. Valid values for both of these cells are given. 

These values drive the Day Cnt calculation, which is the year fraction between accrual start and accrual end of that rate.

Fixed Rate Accrual Dates

The accrual start date for the rate is taken from the payment schedule (accrual end adjusted date), one frequency period back. 

The accrual end date for the rate is taken directly from the payment schedule (accrual end adjusted date).
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Floating Rate Definition

Floating Rate Index Section

The floating rate section consists of visible rate/day count/vol columns, and two levels of hidden calculations. The first hidden level calculates the dates and forward-unadjusted rates, the second calculates adjustments for that rate. 

The first level of hidden columns may be made visible by selecting a cell within the floating rate area and using the Trade->Rate Index->View More menu option, or the Ctrl-Shift-M key combination. Apply the same technique again to unhide the second level of detail. They may be hidden again by using the Trade->Fixed Rate->View Less menu option, or the Ctrl-Shift-L key combination. 

Any number of rate indices may be added into the trade, using the Trade->Rate Index->Add menu option. They may also be removed (except the first) by selecting a cell within the index to be removed and then using the Trade->Rate Index->Remove menu option.

Floating Rate Index Currency

The floating rate currency determines which market data is used to derive the forward rates. By default, this currency will be the same as the payment currency.

Where it is necessary to derive rates from markets other than the payment currency, select a cell within the rate index area and use the Trade->Rate Index->Currency menu option. Select the required currency from the selection list, and (if prompted) allow the market page to be added automatically. The forward rates will now be derived off the zero curves from the specified market.

Floating Rate Index CMS/MM Setting

This value determines whether Money Market or Swap/Bond conventions are used in the derivation of forward rates, duration and convexity calculations.

By default, the floating index is a money-market rate, and therefore the value is defaulted to "M". If the maturity of the rate is set as non-money market, then this cell should be set as "C".

Floating Rate Index Maturity

The maturity of the rate determines the time between the rate start date and the rate end date (in the first level of hidden calculations). These dates are in turn used to determine the unadjusted forward rates. The maturity of the rate is unrelated to the frequency at which the rate pays, although by default the maturity is derived from the frequency (required for vanilla swaps).

The maturity may be changed to any valid date interval.

Floating Rate Index Arrears Setting

This value determines whether the rate starts when the accrual period ends.

By default, the rate will start and accrual will start at the same time and therefore the value is set as "N". If the rate is to be set in arrears, then this cell should be set as "Y".

Floating Rate Index Payment Frequency

The Frq cell determines the frequency at which the floating rate is paid.

It must be at most as frequent as the payment schedule frequency. If it is less frequent than the payment schedule frequency (e.g. annual against semi-annual schedule), then formulae for the fixed coupons should be deleted in the Fixed Cash flow area on the appropriate dates.

Floating Rate Index Day Count Convention

The day count convention for the rate is derived from the Days and Basis. Valid values for both of these cells are given.

These values drive the Day Cnt calculation, which is the year fraction between accrual start and accrual end of that rate.
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Using the Option Section

Option Section

The option section is a self contained area for the calculation of an option on a floating rate index.

By default, the section is hidden. Use the Trade->Option->View menu option to toggle between hidden and unhidden.

Any number of sections may be added, through the Trade->Option->Add menu option. Conversely, sections may also be removed (except the first) by selecting a cell within the section and using the Trade->Option->Remove menu option.

If no spread options are required on the trade sheet, then the Trade->Option->Remove All will permanently remove any of these areas. This has the effect of improving Excel recalculation times. The Remove All action cannot be reversed.

Inputs

The option is calculated on a Floating Rate Index, which should be modelled correctly. Set the Use Index cell within the option area as the number assigned to the Rate Index. This choice drives the rates shown within the Forward U/L, Fwd Vol and Yrs to Expiry columns.

The option type may either be Vanilla or a Binary. This choice drives the underlying Analytics Library function used to calculate the option premium.

A spread may be applied on top of the Fwd Vol. Specifying the spread in the inputs area will apply a constant spread over all vols.

The option may be a call or a put. Use the letters "C" or "P" accordingly.

The strike is entered on a caplet basis, but by default, the next strike is the same as the previous. Therefore it is generally only required to enter the first strike if it is constant across all caplets.

Outputs

Calculation is provided for the option premium and delta.

Using the Option Premium

The option may be included in the total PV of the trade sheet by setting up coupon flows that reflect the premiums.

These new flows are generally modeled within the blank Floating Cash flows area. The formula for the cash flow amount is (Outstanding Principal * Floating Rate year fraction * Option Premium).

Modeling these flows in this column will cause them to be included in the Sum Float column, and therefore the trade sheet PV.

Using the Barrier Section
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Barrier Option Section

The barrier option section is a self-contained area for the calculation of an option on a floating rate index, provided that the rate (or another) does not cross a particular level, in a particular direction. 

By default, the section is hidden. Use the Trade->Barrier->View menu option to toggle between hidden and unhidden. 

Any number of sections may be added, through the Trade->Barrier->Add menu option. Conversely, sections may also be removed (except the first) by selecting a cell within the section and using the Trade->Barrier->Remove menu option. 

If no spread options are required on the trade sheet, then the Trade->Barrier->Remove All will permanently remove any of these areas. This has the effect of improving Excel recalculation times. The Remove All action cannot be reversed.

Inputs

The option is calculated on one or two Floating Rate Indices, which should be modelled correctly. Set the Payment Index cell within the option area as the number assigned to the Rate Index for the rate, which will be paid. Set the Barrier Index cell, as the number assigned to the Rate Index which will be observed. This choice drives the rates shown within the respective Forward U/L, Fwd Vol and Yrs to Expiry columns.

The option may be a call or a put. Use the letters "C" or "P" accordingly.

The barrier level may be activated in an upwards or downwards direction. Use the letters "U" or "D" accordingly.

The barrier may knock the option payments in or out. Use the letters "I" or "O" accordingly.

A spread may be applied on top of the Fwd Vol for both payment and barrier rates. Specifying the spread in the inputs area will apply a constant spread over all vols.

The strike is entered on a caplet basis, but by default, the next strike is the same as the previous. Therefore it is generally only required to enter the first strike if it is constant across all caplets.

The barrier level is also entered on a caplet basis, and the same logic applies.

If there is a correlation between the two rates, it should be entered within the Pay-Bar Crln column. Again, subsequent caplets by default use the correlation from its predecessor.

Outputs

Calculation is provided for the option premium and rebate probabilities.

Using the Option Premium

The option may be included in the total PV of the trade sheet by setting up coupon flows that reflect the premiums.

These new flows are generally modeled within the blank Floating Cash flows area. The formula for the cash flow amount is (Outstanding Principal * Floating Rate year fraction * Option Premium).

Modeling these flows in this column will cause them to be included in the Sum Float column, and therefore the trade sheet PV.
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Using the Swaption Section

Swaption Section

The swaption section is a self-contained area for the calculation of European, Multi-European and American style swaptions.

By default, the swaption section is hidden. Use the Trade->Swaption->View menu option to toggle between hidden and unhidden.

Any number of swaption sections may be added, through the Trade->Swaption->Add menu option. Conversely, swaption sections may also be removed (except the first) by selecting a cell within the section and using the Trade->Swaption->Remove menu option.

If no swaptions are required on the trade sheet, then the Trade->Swaption->Remove All will permanently remove any swaption areas. This has the effect of improving Excel recalculation times. The Remove All action cannot be reversed.

Inputs

The details of the underlying swap can be entered similar to swap template for Accrual/Payment Schedule Configuration, Trade Principal Modeling, Cash flow Modeling, Fixed Rate Definition and Floating Rate Definition.

The option details section allows entry for those details specific to the option. The general option details should be used to provide the option type (Call/Put, European/American) and the notification day details. The notification date(s) for the swaption may be defined to be some

kind of offset from the corresponding exercise date (e.g. 2 months, 1 month and 1 day etc.). Each offset can be one of the following:

· A number of calendar days.

· A number of business days 

Principals and Coupons

The principal and coupons model the underlying swap upon which the option is being written.

The principal and coupon details are taken directly from the first two columns in the fixed cash flows area. The associated dates are taken directly from the payment schedule.

Hence, the underlying should be modeled through cash flows in the fixed cash flows area.

Strikes

The strikes define at what point in time the option may be exercised.

The dates are taken directly from the payment schedule, the strike amount is taken from the outstanding principals column.

The forward volatilities are interpolated from the Swaption volatilities on the payment currency market sheet, and include the volatility spread from input area.

Calculation

Due to the time taken to calculate a swaption premium, a Calculation flag controls the calculation.

When set as zero, no calculation will take place, and all swaption values will be set as zero on recalculation.

When set as one, the outputs will be calculated and reported.

Using the result

The swaption premium is calculated to the payment currency value date.

Therefore, to include the premium in the PV of this sheet, it should be referred to in the cash flow area, on the ccy Value Date row.

Using the Spread Option Section
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Spread Option Section

The spread option section is a self-contained area for the calculation of an option on the spread between two floating rate indices.

By default, the section is hidden. Use the Trade->Spread Option->View menu option to toggle between hidden and unhidden.

Any number of sections may be added, through the Trade->Spread Option->Add menu option. Conversely, sections may also be removed (except the first) by selecting a cell within the section and using the Trade->Spread Option->Remove menu option.

If no spread options are required on the trade sheet, then the Trade, Spread Option, Remove All will permanently remove any of these areas. This has the effect of improving Excel recalculation times. The Remove All action cannot be reversed.

Prerequisites

At least two floating rate indices must be available on the trade sheet, which should define different rates.

Inputs

The spread is defined as being the difference between the rate described by index n and the rate described by index m. Use the numbers assigned to the rate index areas in the required order.

The option may be a put or a call. Use the letters P and C accordingly in the Option Type cell.

The strike is defined on a per-row basis, but by default, the next strike is set to be the same as the previous. Hence it is usually only necessary to enter the first strike. On recalculation, the others will be set correctly.

The same applies to the Basis Point Volatility on the spread.

Outputs

Calculation of Premium and Deltas.

Using the Option Premium

The option may be included in the total PV of the trade sheet by setting up coupon flows that reflect the premiums.

These new flows are generally modeled within the blank Floating Cash flows area. The formula for the cash flow amount is (Outstanding Principal * Floating Rate year fraction * Option Premium).

Modeling these flows in this column will cause them to be included in the Sum Float column, and therefore the trade sheet PV.
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Using the Basket Section

Basket Section

The basket option section calculates the composite rate and volatility of all rate indices defined on the sheet.

The section consists of individual basket premium calculations and a shared correlation’s matrix and weighting area.

By default, the section is hidden. Use the Trade->Basket->View menu option to toggle between hidden and unhidden.

Any number of sections may be added, through the Trade->Basket->Add menu option. Conversely, sections may also be removed (except the first) by selecting a cell within the section and using the Trade->Basket->Remove menu option.

If no baskets are required on the trade sheet, then the Trade->Basket->Remove All will permanently remove any of these areas. This has the effect of improving Excel recalculation times. The Remove All action cannot be reversed.

Inputs

Inputs to the calculation are the defined rates (in the individual rate index sections), and weights for each rate in each basket.

The rates should be configured as necessary.

The weights are applied as a multiple of the individual forward rate. Within the weight table, the rate indices are represented by currency, in the same order as the rates themselves.

Outputs

Calculation of premium, composite rate and volatility are made

The composite rate can be employed within the other option areas to provide basket optionally.

Using the Basket Rate

The composite Basket Rate may be used wherever a floating rate is used. Default formulae for the rates and volatilities should be overtyped with references to the basket section.

The SWAP Template

The SWAP template is designed for modeling vanilla swaps and swaptions.

The swap sheet differs from the CUPS sheet in that payment and accrual dates coincide.

Accrual/Payment Schedule Configuration

Payment frequency

The payment frequency defines the regular interval between coupon payments.

The frequency of the accrual schedule should be the greater of any fixed/floating frequencies that are modeled on the same sheet.

Valid letters are shown to the right of the cell.

Effective date

The effective date can be used to move the start of the payments forward in time.

The cash flow streams will still be PV'd back to the currency value date.

1st Regular Accrual Date / 1st Roll date

A front stub can be defined by setting this date forward from the effective date.

1st Regular Row / 1st Roll date

Setting this to n provides n additional rows where the payment date = effective date.

This is useful where multiple up-front payments are being made, and can be modeled separately.

Bad Day Convention

The bad day convention controls how the unadjusted payment/accrual dates are moved to adjusted dates.

Adjustment is made provided that the Adjust Dates flag is set as 1.

Valid letters are shown to the right of the cell.

Coupon Payment Dates

Coupons will be paid (by default) on the Payment/Accrual End Adjusted dates.

Trade maturity

The maturity of the trade is (accrual frequency * number of cash flow rows), notwithstanding any stubs or upfront rows.

Use the Trade->Make Rows ... menu option to modify the maturity of the trade.

It is recommended that only as many rows as necessary is used, to prevent unnecessary calculation.

Trade Principal Modeling

Principal

The principal for the trade sheet is set in the PPL cell. It should be adjusted for FX rates if applicable.

It may be set negative to reverse the default direction of the coupon payments.

Principal Flows

The principal flows determine at which payment dates any principal exchanges occur.

Normally, you would have =PPL against the trade effective date, and =-PPL against the trade end date.

If you require an amortizing or accreting stream, then these additional principal payments are set in the Principal Flow column.

For example, a 5 year annual amortizing stream would have =PPL against the effective date, and =-PPL/5 on each of years 1,2,3,4 and 5.

Outstanding Principal

The outstanding principal, at any payment date is given as the (outstanding principal + any principal flow) at the previous payment date.

Normally, any coupon payment calculation will use the outstanding principal on the payment date.

Cash flow Modeling

Fixed Cash flows

Fixed principal flows, coupon flows and any other fixed-style flows are modeled together, and summed into the Sum Fixed column.

Fixed coupons are calculated as (fixed rate * outstanding principal * year fraction).

Floating Cash flows

Floating principal flows, coupon flows and any other floating-style flows are modeled together, and summed into the Sum Float column.

Floating coupons are calculated as (floating rate * outstanding principal * year fraction).

Total PV

The summed Fixed and Floating cash flows are PV'd back to ccy Value Date, which are then summed together to give a total PV.

This value is used on the left-hand side as the PV of the trade, and hence on the Summary page.

Fixed Rate Definition

Fixed Leg Section

The fixed leg section consists of visible rate/day count columns, and hidden accrual start/end and day count columns.

The hidden columns may be made visible by selecting a cell within the fixed leg area and using the Trade->Fixed Rate->View More menu option, or the Ctrl-Shift-M key combination. They may be hidden again by using the Trade->Fixed Rate->View Less menu option, or the Ctrl-Shift-L key combination.

Fixed Coupon Rate

A cell is supplied (CPN) for setting a constant fixed rate over the length of the trade.

If the fixed rate is not constant, different rates may be entered in the Fixed Rate column against the appropriate payment dates.

Fixed Rate Payment Frequency

The Frq cell determines the frequency at which the fixed rate is paid.

It must be at most as frequent as the payment schedule frequency. If it is less frequent than the payment schedule frequency (e.g. annual against semi-annual schedule), then formulae for the fixed coupons should be deleted in the Fixed Cash flow area on the appropriate dates.

Fixed Rate Day Count Convention

The day count convention for the rate is derived from the Days and Basis. Valid values for both of these cells are given.

These values drive the Day Cnt calculation, which is the year fraction between accrual start and accrual end of that rate.

Fixed Rate Accrual Dates

The accrual start date for the rate is taken from the payment schedule (accrual end adjusted date), one frequency period back. 

The accrual end date for the rate is taken directly from the payment schedule (accrual end adjusted date).

Floating Rate Definition

Floating Rate Index Section

The floating rate section consists of visible rate/day count/vol columns, and a set of hidden columns, which calculate the forward rates.

The hidden columns may be made visible by selecting a cell within the floating rate area and using the Trade->Rate Index->View More menu option, or the Ctrl-Shift-M key combination. They may be hidden again by using the Trade, Fixed Rate, View Less menu option, or the Ctrl-Shift-L key combination.

Any number of floating rates may be added by using the Trade->Rate Index->Add menu option. They may also be removed (except the first) by selecting a cell within the rate index to be removed, and using the Trade->Rate->Index->Remove menu option.

Floating Rate Index Currency

The floating rate currency determines which market data is used to derive the forward rates. By default, this currency will be the same as the payment currency.

Where it is necessary to derive rates from markets other than the payment currency, select a cell within the rate index area and use the Trade->Rate Index->Currency menu option. Select the required currency from the selection list, and (if prompted) allow the market page to be added automatically. The forward rates will now be derived off the zero curves from the specified market.

Floating Rate Index Payment Frequency

The Frq cell determines the frequency at which the floating rate is paid.

It must be at most as frequent as the payment schedule frequency. If it is less frequent than the payment schedule frequency (e.g. annual against semi-annual schedule), then formulae for the fixed coupons should be deleted in the Fixed Cash flow area on the appropriate dates.

Floating Rate Index Day Count Convention

The day count convention for the rate is derived from the Days and Basis. Valid values for both of these cells are given. 

These values drive the Day Cnt calculation, which is the year fraction between accrual start and accrual end of that rate.

Using the Swaption Section

Swaption Section

The swaption section is a self-contained area for the calculation of European, Multi-European and American style swaptions.

By default, the swaption section is hidden. Use the Trade->Swaption->View menu option to toggle between hidden and unhidden.

Any number of swaption sections may be added, through the Trade->Swaption->Add menu option. Conversely, swaption sections may also be removed (except the first) by selecting a cell within the section and using the Trade->Swaption->Remove menu option.

If no swaptions are required on the trade sheet, then the Trade->Swaption->Remove All will permanently remove any swaption areas. This has the effect of improving Excel recalculation times. The Remove All action cannot be reversed.

Inputs

The details of the underlying swap can be entered similar to swap template for Accrual/Payment Schedule Configuration, Trade Principal Modeling, Cash flow Modeling, Fixed Rate Definition and Floating Rate Definition.

The option details section allows entry for those details specific to the option. The general option details should be used to provide the option type (Call/Put, European/American) and the notification day details. The notification date(s) for the swaption can be defined to be offset from the corresponding exercise date (e.g. 2 months, 1 month and 1 day etc.). Each offset can be one of the following:

· A number of calendar days.

· A number of business days 

Principals and Coupons

The principal and coupons model the underlying swap upon which the option is being written.

The principal and coupon details are taken directly from the first two columns in the fixed cash flows area. The associated dates are taken directly from the payment schedule.

Hence, the underlying should be modeled through cash flows in the fixed cash flows area.

Strikes

The strikes define at what point in time the option may be exercised.

The dates are taken directly from the payment schedule, the strike amount is taken from the outstanding principals column.

The forward vols are interpolated from the Swaption vols on the payment currency market sheet, and include the vol spread from the input area.

Calculation

A Calculation flag controls calculation.

When set as zero, no calculation will take place, and all swaption values will be set as zero on recalculation.

When set as one, the outputs will be calculated and reported.

Using the result

The swaption premium is calculated to the payment currency value date.

Therefore, to include the premium in the PV of this sheet, it should be referred to in the cash flow area, on the ccy Value Date row.

The USER Template

The USER template does not model any instruments, but is a free-form sheet for ad-hoc modeling.

To include the PV of any calculations within the PV of the trade as a whole, reset the formula in the left-handside for the ccy PV, ccy Value Date cell to reference the PV calculation on the right-hand side. 

This PV value will be translated into USD and referenced in the Summary sheet.

Template Accuracy

All wrappers have been implemented to ensure consistency in presentation. The numerical accuracy used for various standard inputs is as listed below:

All coupon/cap/floor/trigger levels are quoted to 5 d.p. e.g. 5.00000%

All amortization levels are quoted to 3 d.p. e.g. 100.000%

All index weights are quoted to 2 d.p. e.g. 0.50

All spreads are quoted to 3 d.p. e.g. 10.000 b.p.

All amounts are quoted to 0 d.p. e.g. 1000000

All factor weights, mean reversions and correlations are quoted to 4 d.p. e.g. 0.9000

N.B. This is the accuracy with which the numbers are written out to the data files and cannot be increased by increasing the accuracy in the spreadsheet. If greater accuracy is required contact your local Aladdin support.

Inputs Area

The input area allows the instrument specifics to be defined. Many of the values are "sensible defaults", but all may be changed. The layout of the area follows the required ordering in the data file, to allow easier cross-referencing of the two. There are two possible combinations of zero curve available; controlled by the "Use Zero Curves" switch. If set to 0 the Mid zero is used for both discounting and estimation curve, which ignores the effects of Cost of Funds and Currency Basis. If set to 1 the discount and estimation curves are built, incorporating the effects of Cost of Funds and Currency Basis.

Schedule Areas

The templates all provide a schedule area, to the right of the inputs area, for modeling amortization, coupon step-ups along with option strikes and levels where applicable.

The depth of the schedule can be modified by using the Trade->Make Rows menu option. The frequency can be modified by the "Schedule Frequency" cell in the input area.

General points:

Entries in the schedule should only be put in valid rows as defined by the underlying product (i.e. a semi-annual underlying will not accept step-up entries on quarterly dates).

Amortization is specified in % of notional. The sum of the amortization entries should equal the Original Notional Percentage.

The first coupon defines the start of the underlying, and the rate that applies forwards from that date. Subsequent step-up coupons define the rate that applies forwards from that date. The coupon payment on that date will be based on the previous coupon rate.

Option exercises occur on the specified date. American options require at least 2 exercise dates, which define the start and end of the option observation.

Option exercises occurring at a specified frequency, e.g. A, S, Q, M, require at least 2 exercise dates, which define the start and end of the option observation. The date separation must be consistent with the exercise frequency. 

Note 1. There are two possible combinations of zero curve available; controlled by the "Use Zero Curves" switch. If set to 0 the Mid zero is used for both discounting and estimation curve, which ignores the effects of Cost of Funds and Currency Basis,. If set to 1 the discount and estimation curves are built, incorporating the effects of Cost of Funds and Currency Basis.

Note 2. Although the whole Base Volatility surface is passed into the functions the underlying wrapper only uses one underlying maturity, which is selected based on the money market frequency (i.e. semi-annual uses the 6m base-vol curve; quarterly uses the 3m base-vol curve).

Product Descriptions

Cap

This product is a cap (or a floor) on a floating leg of an arbitrary swap.  In order to reflect the uncertainty of the floating index the model evolves it through time with the help of a set of zero coupon bonds resetting at different maturities.

This model uses a tree to describe the factors driving the short-term interest rate.  The number of factors can vary from one to three and these factors follow either a normal or lognormal, mean reverting process.

Limitations

The spread to the floating index is added to both the value of the index and the strike of the cap for intrinsic value calculations.  Consequently, it has no effect on a cap with simple payment, but it does have effect on a cap with compounded payment.

Chooser/Survivor Cap

This template operates in two modes in order to calculate either the Chooser or the Survivor Cap, which can be controlled via the PRODUCT SELECTION category.

A chooser cap (or a floor) is where the owner has the right to exercise a limited number of caplets.  The underlying cap is modeled as in the Cap product.

A survivor cap (or a floor) is where the owner can exercise only a limited number of caplets.  The caplets are exercised automatically (no choice) when they end up in-the-money. The underlying cap is modeled as in the Cap product.
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Both models use a tree to describe the factors driving the short-term interest rate.  The number of factors can vary from one to three and these factors follow either a normal or lognormal, mean-reverting process.

Limitations

The maximum number of caplets has to be updated as the deal goes through and some caplets are exercised.

The spread to the floating index is added to both the value of the index and the strike of the cap for intrinsic value calculations.  Consequently, it has no effect on a cap with simple payment, but it does have effect on a cap with compounded payment.

The value of the survivor cap is a discontinuous function of the value strike or level of rates.  The discrete character of the tree calculations results in numerical errors in the evaluation of discontinuous payoffs.  These errors are small when compared to the value of the option, but may be quite significantly change the value of the delta of the option.  This implementation addresses this problem by allowing for modification – polynomial smoothing of payoff – in its discontinuous part.  The value of smoothed option is slightly different from the value of the un-smoothed one, but it’s delta reflects much better the true theoretical delta.

Knock-Out/In Cap

This product consists of a swap fixed coupon vs. floating index, which is cancelled/comes to existence depending on the value of the knockout/in index.  The knockout/in range is specified by low and high barriers and the knockout/in event is possible only if the knockout/in index is within (or outside) the range.  The knockout/in event list is specified separately from the swap specification allowing for all possible knockout/in-monitoring frequencies.  Both legs of the underlying swap are valued, so the value of the floating leg upon exercise reflects the uncertainty inherent in the value of the floating index.

This model uses a tree to describe the factors driving the short-term interest rate. The number of factors can vary from one to three and these factors follow either a normal or lognormal, mean-reverting process.

Limitations

Estimation of the floating index and knockout/in index may lead to a small numerical error as a result of necessary interpolation of zero coupon rates required in indices calculations.  This error happens when knockout/in dates are not equally spaced.

Intrinsic value of the knockout/in swap is a discontinuous function of the value of the knockout/in index.  The discrete character of tree calculations results in numerical errors in the evaluation of discontinuous payoffs.  These errors are small when compared to the value of the option, but may be quite significantly change the value of the delta of the option.  While this problem is mitigated in American by averaging between discontinuities at different times, it may be quite significant for single option.  This implementation addresses this problem by allowing for modification-polynomial smoothing of payoff – in its discontinuous part.  The value of the smoothed option is slightly different from the value of the un-smoothed one, but it’s delta reflects much better the true theoretical delta.

The model allows for a rebate in knockout swap.  This rebate is to be paid immediately upon knockout (as opposed to being paid on the option expiration).  There is no rebate allowed for knock-in swap.

The model allows for three different conventions for the swap accrued.  In the case of the knockout partway through the swaplet these are: 1) no stub- there is no payment of accrued; 2) bond stub – the accrued is paid immediately; 3) swap stub – the accrued is paid on the coupon payment date.  These three conventions are allowed for reset-in-advance swap, while the bond stub is disallowed for the reset-in-arrears swap.  Please note that the “natural” accrued conventions are: no stub for knockout and knock-in, bond stub for the knockout, and swap stub for the knock-in.

Sticky/Adjustable Collar

This function calculates the price of a floater with embedded sticky or adjustable caps/floors/collars, or the option-only part of these instruments.  The observation events are flexible and are input by a user.  For an option only structure, each payment equals the difference between a cap and a floor with strikes determined by the life cap/floor and a lookback value with cap/floor spreads.  For a floater, the coupon is the portion of the observed index that falls in the range between the cap and floor strikes.  A lookback value equals either a previous coupon (for a sticky), or a value of another index (for an adjustable).

The payments are determined by the value of a specified index capped with either a previous coupon (sticky), or a value of another index, possibly on a different date (adjustable).  For a floater, the coupon is a portion of the observed index that falls in the range specified by life cap/floor and lookback value with cap/floor spreads.  For an option, the payment is a portion of the index falling outside the range.
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More precisely, for each payment date Ti the user specifies the following:

Reset date Ri

Lookback date Li

Psi, Csi and Fsi – payment, cap and floor spreads respectively

Remaining notional Ni

Le the lookback value Xi be

the previous coupon rate Ci-1 at time Ri-1 for sticky (in this case must have lookback date Li = Ri-1), or

the adjustable index value at time Li for adjustable structure.

And let also


CapStrikei = MIN(lifeCap, Xi + Csi)


FloorStrikei = MAX(lifeFloor, Xi + Fsi)

Then the coupon rate Ci is determined as follows:


Ci = MIN(capStrikei, MAX(floorStrikei, currentIndex + Psi))

And an option rate


Oi = MAX(currentIndex + Psi – capStrikei, 0) – MAX(floorStrikei – (currentINdex + Psi), 0).

Finally, the payment at Ti equals


Ci * Ni * accruedDCfractioni

For a floater with embedded option, or


Oi * Ni * accruedDCfractioni

for an option.  Here accrued Dcfractioni is a daycount fraction between accrued start and accrued end dates for Ti.

This model uses the multi-factor Monte-Carlo engine.  The number of factors can vary from one to three and these factors follow either a normal or lognormal, mean-reverting process.

Special features:

If the normal model implies negative rates for more than 0.01% of the paths, this will cause the current implementation of MC to fail.

Lookback dates have to be smaller of equal the corresponding reset dates.  In the case of equality, an adjustable structure effective prices a spread option.

Entries with payment dates <= value date are ignored.

For each payment date, a user is allowed to input a ‘preset rate’ and a ‘preset lookback’.  In general, if not 0., they are used instead of calculated index values.  Please note a special rule for lookback values with lookback date before or on value date.
Rules for ‘preset rate’ values:

If reset date < value date, ‘preset rate’ is always used as currentIndex is above calculations

If reset date >= value date, and ‘preset rate’ is 0., currentIndex is calculated off diffused forward rates

If reset date >= value date, and ‘preset rate’ is not 0., then ‘preset rate’ overrides calculated index, and is used as currentIndex value

Rules for ‘preset lookback’ values:

If lookback date < value date for adjustable, or < first reset date for sticky, and ‘preset lookback’ is not 0., then it is used as Xi above.  If ‘preset lookback’ is 0., then the lookback value is ignored, and in the above calculations


capStrikei = lifeCap


floorStrikei = lifeFloor

if lookback date > value date, and ‘preset lookback’ is not 0., then ‘preset lookback’ is used as Xi for both stick and adjustable structures; otherwise Xi is calculated as described above.

Swaption

Product Descriptions

This product consists of an option on an interest rate swap where a fixed coupon is paid against a value of a floating index.  In this model, both legs of the underlying swap are valued so that the value of floating leg upon exercise reflects the uncertainty inherent in the value of the index.

This template supports single European swaption, multi European (Bermudan) swaption and American swaption.  

Analytics

This model uses a tree to describe the factors driving the short-term interest rate. The number of factors can vary from one to three and these factors follow either a normal or lognormal, mean-reverting process.

Limitations:

American options are in fact priced as multi-European options where exercise is possible at every time step.  This will slightly underestimate the price of the American option.

This implementation supports three option stub conventions concerning the payments of the accrued cash flow when exercising partway through an accrued period.  The bond stub convention implies immediate accrued exchange and a full coupon payment on the next coupon date (this is the same convention as in an option to cancel a swap).  The swap stub convention implies an adjustment (decrease) to the next coupon payment, which reflects the length of the remaining fraction of the coupon period (this is the same convention as in an option to enter into a swap).  The no stub convention implies payment of the full coupon on the next coupon date.

Please note that the strike on the floating leg is paid on the exercise date and not on the swap accrual start date.

The estimation of the index is required in the case of an accrual payment in the middle of a accrual period for a swap with floating side resetting-in-advance.  This is due to the fact that the index resets on a date earlier than the exercise date (i.e. when the accrued is calculated), thus, in the backstepping procedure on the tree, it cannot yet be known.  This problem is more significant for shorter maturity indexes.

Trade Entry

The details of the underlying swap can be entered similar to swap template for Accrual/Payment Schedule Configuration, Trade Principal Modeling, Cash flow Modeling, Fixed Rate Definition and Floating Rate Definition.

The option details section allows entry for those details specific to the option. The general option details should be used to provide the option type (Call/Put, European/American) and the notification day details. The notification date(s) for the swaption can be defined to be offset from the corresponding exercise date (e.g. 2 months, 1 month and 1 day etc.). Each offset can be one of the following:

· A number of calendar days.

· A number of business days 
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Single European Swaption

To model a single European Swaption, user should choose type Single and specified the First Exercise in years related to the valuation date or override the formula in Dates.
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Multi-European (Bermudan) Swaption

To Model a multi-European Swaption, user should choose type Euro, specify the first exercise date in year relative to valuation date and the exercise frequency.
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American Swaption

If the option is specified to be American a strike interpolation method must be selected. There are two choices.

· Linear - For dates between two given date in the strike schedule the strike to be used is linearly interpolated.

· Staircase - For a strike date between two given dates in the strike schedule the strike corresponding to the earlier of the two dates is used.
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Model/Pricing Parameters

Currency Protected Swap

The CUPS executable provides a tool with which to price currency protected swaps.  The user can specify up to four swap legs: floating and fixed, each one in foreign or in domestic currency.  All payments are made in domestic currency, so that the domestic floating leg is a usual floating leg, but the foreign floating leg is priced considering the currency protection effect.

This model uses a two-factor tree to describe the two stochastic variables at play: the short-term interest rate of each one of the two currencies.  The description of each interest rate assumes a one-factor, lognormal, mean-reverting process and is consistent with the one-factor interest rate products.

The model supports stubs, resets in arrears, amortizing principals and step up fixed coupons -- all with separate schedules for the foreign and domestic legs.  Start dates before value date are coped with by dropping previously paid cash flows and by taking as input any fixings, which may have occurred.

The two notional amounts (one referring to the domestic legs and the other to the foreign legs) are specified in domestic currency.  The direction of the flows is obtained from the sign of the notional and it is assumed to be the same for all flows (floating and fixed) in each currency.  In other words, if the foreign notional is positive, then both foreign fixed and foreign floating flows are received.

Limitations
Correlations must be within the [-0.95,0.95] interval

CUP Binary

The product in question has a simple binary pay-off, contingent on the level of a currency protected index being outside (or inside) the range delimited by a lower and an upper barrier levels.

This model uses a two-factor tree to describe the stochastic variables at play: the short-term interest rate of each one of the two currencies.  The description of each interest rate assumes a one-factor, lognormal, mean-reverting process and is consistent with the one-factor interest rate products.

In the binary description, one or more observation dates are specified.  At each observation date, the binary index is computed based on two given index maturities, the denomination of each one (i.e. domestic or foreign) and their respective weights.  As soon as an observation date arises where the level of binary index is outside (or inside, depending on inputs) the barrier range, the binary pay-off is paid either immediately or on a given delayed date.

Limitations

Correlations must lie within the [-0.95,0.95] interval.

If delayed payment is specified, then delayed payment date must be beyond the binary observation dates/window.

CUPS Option

This product consists of an option on a currency-protected swap.

This model uses a two-factor tree to describe the stochastic variables at play, namely the short term interest rate of each one of the two currencies.  The description of each interest rate assumes a one-factor, lognormal, mean-reverting process and is consistent with the one-factor interest rate products.

The description of the underlying cups is consistent with that found in the CUPS executable: the model supports stubs, resets in arrears, amortizing principals, step up fixed coupons and payment on a compounding rate rule all with separate schedules for the foreign and domestic legs.  Start dates before value date are coped with by dropping previously paid cash flows and by taking as input any fixings, which may have occurred.  The user is referred to the CUPS User Guide for further information.

The strike for the underlying option is specified as an amount in domestic currency.  Exercise partway through an accrual period is dealt with using one of the three option stub rules: swap, bond or none.  The swap convention implies 'stubbing' of the first coupon; the bond convention implies full payment of the first coupon on its regular date and immediate receipt of the accrual so far (flows of opposing direction) and the no stub convention implies full payment of all future flows.  For all conventions, whenever the value of a floating index is required partway through a period, the index is estimated as required.  This procedure does not match the market convention exactly for the cases where the reset is in advance.

Limitations

Correlations must lie within the [-0.95,0.95] interval.

If exercise dates are to be generated according to a given frequency, first and last exercise dates must result in an integer number of periods, i.e. stubs are not allowed.

Notification periods must be specified so that a swap start must not fall within the notification period of the following exercise date.  In other words, notification periods must not overlap.

For a floating leg paying on a compounding rate rule, exercise partway through an accrual period is not supported.
American exercise is modeled approximately by exercising on every node available in the tree within the specified exercise time window.
Knock-Out/In CUPS

This product consists of a knock out (or in) option on a currency protected swap.  On the specified observation dates, the currency protected swap can knock out (or in) depending on the level of a weighted combination of two indices being inside (or outside) a given barrier range.  Each one of the indices (market rates) used for the knock out (in) condition can be observed on the domestic as well as the foreign currency.

This model uses a two-factor tree to describe the stochastic variables at play, namely the short term interest rate of each one of the two currencies.  The description of each interest rate assumes a one-factor, lognormal, mean-reverting process and is consistent with the one-factor interest rate products.

The description of the underlying cups is consistent with that found in the CUPS executable: the model supports stubs, resets in arrears, amortizing principals, step up fixed coupons, capped/floored floating legs and payment on a compounding rate rule all with separate schedules for the foreign and domestic legs.  Start dates before value date are coped with by dropping previously paid cash flows and by taking as input any fixings, which may have occurred.  The user is referred to the CUPS User Guide for further information.

Knock out (or in) partway through an accrual period is dealt with using one of the three stub rules: swap, bond or none.  The swap convention implies 'stubbing' of the first coupon; the bond convention implies full payment of the first coupon on its regular date and immediate receipt of the accrual so far (flows of opposing direction) and the no stub convention implies full payment of all future flows.  For all conventions, whenever the value of a floating index is required partway through a period, the index is estimated as required.  This procedure does not match the market convention exactly for the cases where the reset is in advance.

Limitations

Correlations must lie within the [-0.95,0.95] interval.

If knock out/in dates are to be generated according to a given frequency, first and last knock out dates must result in an integer number of periods, i.e. stubs are not allowed.

Cut off delay periods must be specified so that a swap termination (or start) must not fall within the delay period of the following knock out (or in) date.  In other words, delay periods must not overlap.

For a floating leg paying on a compounding rate rule, exercise partway through an accrual period is not supported.

American knock out (or in) is modeled approximately by making an observation on every node available in the tree within the specified knock out (in) time window

Swaps

The Swap and CUPS template sheet allow a large variety of swaps to be modeled.

The modeling generally relies upon a combination of fixed and floating definitions, on one or more template sheets.

Swap Sheet Vanilla Swap
Trade Characteristics


Fixed verses floating payments in the same currency.


Fixed rate is constant across the trade.


Floating rate start and end dates correspond with accrual start and end dates.

Worked Example

7yr 50m DEM, paying annual 5.3% fixed, receiving quarterly 3m Libor.

Setting up the example

Start Aladdin.  Select to add single Swap sheet when prompted.  Activate the USD SWAP(1) sheet.

Change the payment currency to DEM using the Trade->Currency menu option.  In the Accrual/Payment Schedule area, make the Accrual Period frequency “Q”.  Make the trade 7yrs long by making 28 rows using Trade->Make Rows menu option.

Set the principal amount in the Principal cell to be 50,000,000.  Delete the “old” final principal exchange by selecting the cell and using the delete key.  Set the “new” final principal exchange by selecting cash flow (row 28 in the Principal Flow column, and typing = -PPL.  Recalculate.

Set the fixed coupon to be 5.3% by entering 5.3 in the CPN cell.  Recalculate to observe the fixed rate in the Fixed Leg 1 area.  Set the fixed leg frequency to “A” if it is not already.

Annualize the fixed coupon by entering zero for cash flow rows 1, 2 and 3.  Select cells in the fixed coupon column for cash flow rows 1 to 4, and Copy (Ctrl-C).  Select cells in the fixed coupon column for cash flow rows 1 to 28, and Paste (Ctrl-V).

Set the floating leg frequency to “Q” if it is not already.

Recalculate.

Short Cuts

Ctrl-Shift-A - Set variable for solving

Ctrl-Shift-B - Set constraint for solving

Ctrl-Shift-C - Solve (variable and/or constraint must be set first)

Ctrl-Shift-E - View Error Log

Ctrl-Shift-M - View hidden columns

Ctrl-Shift-L - Hide columns

Tools Worksheets
Calibration/Anchoring Tools Overview

Models used in product valuation usually require parameters that are not directly observable in the markets. In some cases, those parameters can be implied in a relatively straightforward manner from market prices (e.g. volatility used in Black’s model); in other cases (e.g. correlation), history can give a rough indication of value. 

Very often however, one needs to go through a more complex calibration process to make sure the model fits the market. In particular, Aladdin incorporates many products that are priced in 1 and 2-factor models where the processes followed by the interest rate are quite complex and are based on a range of non-trivial parameters. 

Aladdin therefore incorporates tools that allow the user to make sure the models adequately represent a specific market. 

General Introduction to Calibration and Anchoring
At a given time, we can get a snapshot of a specific market through a set of its most liquid instruments. Calibration is then used to make sure the model fits this snapshot and thereby provides as good a representation as possible of the market considered. 

The snapshot is the volatility matrix: it is implied from swaps and cap/floors prices using Black’s formula. The goal of calibration/anchoring is to achieve a good fit of the areas of the volatility matrix that the user feels are important (because they represent the most actively traded instruments, or ones which will be used for hedging purposes, or because they determine certain characteristics of the process that are particularly important for the product we want to price).

More precisely, the process is done in two steps: 

1. The calibration step: we look for a general fit of (certain areas) of the volatility matrix. This is done by changing the mean reversions, the correlation and spot volatilities. However the spot volatilities are kept constant within the tree (i.e. they are not time-dependent). The rational behind this first step is to make sure the general assumptions are reasonable for the current market conditions.  When we feel the general fit is good enough, i.e. when we have ascertained that the market considered can indeed be represented with our model, we can start tweaking the model a bit more with no risk of ending up with a meaningless representation.  This is performed in the…

2. Anchoring step; the spot volatilities are allowed to vary in order to fit almost perfectly certain instruments (usually the hedging instruments).

Anchoring is a type of bootstrapping, and is done automatically when the tree is built; however, it can fail if the anchoring points are too frequent or their volatilities too erratic. In such a case, no price will be returned and a message will be written in the error log file.

Calibration minimises the differences between market volatilities and model volatilities calculated with varying parameters. A closed-form approximation is used to avoid having to recalculate the whole tree for each point in the matrix. 

The Calibration tool

The calibration tool is opened in the same way as a trade sheet, using the menu “Trade, Sheet, Add” and choosing “Volatility Calibration sheet”. One needs to set the currency as on any other trade sheets.

The sheet has 3 main areas: 

· left-hand side is the usual Aladdin link area, 

· settings (model parameters, optimisation parameters, etc.);

· volatility/weight matrices are on the right.

The four matrices are: 

· Generated Swaption Volatilities: these are the volatilities calculated using the “Used for display” parameters; 

· Original swaption volatilities: these are the market volatilities, taken directly from the market sheet;

· Differences: the differences between the first two matrices; differences can be calculated in 3 ways depending on the “Difference type” selected in the “Display” area. 

· Weights: these can increase/decrease the importance of certain instruments during the calibration process.

The matrices display is controlled in the “Display” area:
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Calibration is done trying by minimising the weighted-sum of the differences. This is calculated in cell I65 (“weighted”); the unweighted sum is in cell G65 (“Current sum of differences”); the differences can be simple differences (2), absolute differences (3) or squared differences (1).

The display ranges can be modified in “Colour Coding”. Values are expressed in %, e.g. if “blue is less than 0.01”, all values less than 0.01% in the difference matrix will be displayed in blue. The same colour will be applied to the two volatility matrices based on the value of the difference matrix. Hence one can see directly in the volatility matrices which areas are good/bad fits.

The “Generated Swaption Volatilities” calculations are directed from the “Calculation”, “Model Parameters” and “Anchoring” areas that also determine how calibration is done. 
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The “Calculation” switch turns the “Generated Swaption Volatilities” matrix on/off. 

Calibration can be done using a VB or a C optimiser (“Calibration using”). The C optimiser is more limited but faster than the VB one. In particular, the C tool only optimises on the sum of squared differences, independently of what is chosen by the “Difference type” switch; also when started, calibration can not be interrupted and no indication of progress is given.

The generated volatilities can be calculated using a closed-form approximation or backed-out after a full tree calculation (“Use tree in calculation”). The tree option is really only present for the user to check the size of the approximation made if he is interested in doing so. Calculation time is so high that it is not a viable method for calibration.

The “Model Parameters” are similar to those on other exotic pricing sheets.

The “Default” parameters are taken from the market sheet. They are likely to represent the values from the latest calibration for that market. They are displayed for information and are not used.

The “Used for display” parameters are the values used to calculate the “Generated Swaption Volatilities”.

Calibration can be done with or without anchoring. This is also a good way to visualise how anchoring really works. 

While anchoring is done correctly within the sheet (i.e. using only available market volatilities without any interpolation), one can choose to use a separate anchoring sheet (see the anchoring tool section below for more information on the role of anchoring and on how the anchoring tool works). If calibrating using a separate anchoring sheet, one needs to remember to link the parameters on the anchoring sheet to the “Used in display” calibration parameters so that new values tested during calibration are passed to the anchoring object. This is not true for weights, which should be set to constant values on the anchoring sheet (those are not optimised when anchoring is turned on). 

The actual calibration process is controlled in the last area:
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Each parameter’s optimisation can be turned on or off; parameters that do not apply to a specific model are not used even if left on.

One must provide an initial value; at the end of the calibration, the optimised value appears in the “Optimised value” column.

The optimiser avoids values that result in calculation errors, so one does not have to specify obvious ranges for parameters (like correlation between –1 and 1, positive mean reversion and volatility, etc). It is however possible to add constraints. When a constraint is used (1 in the “Use” column), it is compulsory to put a Min AND a Max value.

Finally, the trade-off between speed and precision can be adjusted (“Precision”).

A calibration run is launched in the menu, “Trade, Calibrate”. In VB mode, calculation must be turned on for a calibration run.

In VB mode, the status bar shows the elapsed time, the current weighted sum value and the minimum achieved up to that point (100 means that the parameters currently tested result in an undefined calculation). One can interrupt the macro (by pressing Esc) to stop a run; the best values found up to the interruption will be displayed in the “Optimised Value” column.
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When one has found a satisfactory set of values, it is possible to save the results in an additional sheet for comparison/reference by using the menu “Trade, Save to sheet”, and entering a name for the new sheet. The added sheet also has charts showing the results with the initial and final parameters together with the market values and some differences. Hence one can compare different runs, using different settings and models to find the one which best adjusts to the market conditions.

Adding such a sheet also has the effect of opening the “Calib results” sheet, a summary of all the sheets created; and of adding a new row with a quick description of the results and some space for comments.

The Anchoring tool

Anchoring is included in all Aladdin exotic product sheets. However, the defaults/method used are only valid for simple standard instruments. For instance, a product with monthly coupons will probably fail to price since anchoring will be done by default on all coupon dates, i.e. on numerous volatilities which are only interpolated from what is given by the market. It is better to anchor on the available market volatilities and leave the intermediate values free to be determined by the model in a way consistent with the process used.
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Default anchoring on an exotic swaption sheet

One can have more control on the anchoring process by using the anchoring sheet and defining exactly the instruments to anchor to. The sheet then produces an object which must be linked back to the pricing sheet.

The anchoring sheet is called like a product sheet, by using “Trade, Sheet, Add” and choosing “Vol Anchoring Sheet” in the box. The currency must set as in a regular trade sheet.

 The sheet is divided into 4 zones; as usual, the left-hand side zone is used to transfer parameters between sheet. The remaining areas are:

· the “Model Parameters” area which is used to input the parameters of the model we want to anchor: 

· the “Vol Anchoring” area for precise selection of instruments on which to anchor;

· the Output area in which produces an Excel object is produced that can be linked to a pricing sheet.
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Model parameters are the parameters of the model we want to use. The user should enter the number of factors, the process power and the values for the parameters (mean reversions, etc.).

While the Factor weights have no influence on the anchoring, they should have non-zero values.

“Max spot vol” should be left to 0.  

The Vol. Frequency is simply the number of payments per year for swaps.

The maturity date/index can be a date (e.g. 21/11/2010) or a period (e.g. 10Y). If a date is entered, the model is anchored to e.g. swaptions with final maturities on that date (this is the end of the underlying swap); when an interval is entered, the instruments used have the same underlying tenor.

For instance, an entry equal to 10Y will use instruments in the 10Y column of the volatility matrix, e.g. 1x10, 2x10, etc.

A date will use a kind of diagonal of the matrix.

In other Aladdin sheets (e.g. the calibration tool), a period such as 10Y is entered as 10YCMS, and a date like 21/11/2010 is entered as 10Yfix (interval from today). 
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In the Vol anchoring area, one sees the actual instruments used and their volatility; the anchoring points can be changed and selected/deselected. 

Although it is possible to choose anchoring dates that do not exist in the volatility matrix (like 19M), it is not recommended.  Similarly, the sheet modifies the maturity to avoid interpolating.  Using interpolated volatility is in effect creating fake data and it is preferable to leave the model to its own interpolation to maintain consistency with the rest of the process. 
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When all is done, an object is created in cell “Vol Def Structure”. This object can then be used on exotic pricing sheets with the knowledge that the model used re-prices almost exactly the set of instruments chosen. 

Whilst this document is believed to be accurate, neither MBRM, nor Cygnifi, certify the accuracy or completeness of this information.

January-2003

� EMBED Word.Picture.8  ���





� EMBED Word.Picture.8  ���











[image: image26.png]OPTION DETAILS

Type L Long,Short

C  Put,Call,Straddle

A Amer, Euro, Single

Frequency O AS,0

FirstExercise 000 Years
L
2
B
P
[

Am Stike Interp Linear, Staircase
Not Days

Bus, Cal

BEMN

on

Bad Day Conv
Allowed Loss
Row Offsets 0 1
1) Orfion nclces principal flawrs on expiry bt ot coupan|
flows. 2 Sirke premiums are from JPM perspective

Select Dates Strikes
1 27-NowDD| [
1 98-Nov-05, ol



Aladdin User Guide 
Page 1 of 64
Copyright 2003 All Rights Reserved

MBRM - MB Risk Management

PROPRIETARY AND CONFIDENTIAL MATERIAL.

[image: image27.png]MODEL PARAMETERS

Model Type N Tognormal, Normal
N Factor Parameters s Long, Short
# of factors 1 1,2
Zero curve to diffuse 1 0-Discount, 1~Forward

Process Power 0-Normal, 1=Lognormal
Smoothing factor

# of Std Dev’s to cut tree

Tree PPA_
Factor1  Factor2
Max Spot Vol 0 0
Fact weights 1 B
Meanrev. 0.0 #UA
Correlations AUA

CALIBRATION PARAMETERS

Curve 1 0=Swap VoI,




_1036397374.doc
[image: image1.png]FX/USD [FX]
pal [PPL]

7.0000]
100,000,000

Principal
Flow

Outstanding
Principal

[
0

100,000,000

[
100,000,000
100,000,000
100,000,000
100,000,000
100,000,000
100,000,000








_1036827912.doc
[image: image1.png]OPTION DETAILS

Type L Long,Short

C  Put,Call,Straddle

A Amer, Euro, Single

Frequency O AS,0

FirstExercise 000 Years
L
2
B
P
[

Am Stike Interp Linear, Staircase
Not Days

Bus, Cal

BEMN

on

Bad Day Conv
Allowed Loss
Row Offsets 0 1
1) Orfion nclces principal flawrs on expiry bt ot coupan|
flows. 2 Sirke premiums are from JPM perspective

Select Dates Strikes
1 27-NowDD| [
1 98-Nov-05, ol







